• The price for the GOLD and Unlimited groups has been reduced by 22%. Don't miss the chance to purchase access to hundreds of great resources.
    Coupon: BM_TOPBuy the group

Plugin Upgradeable Hoppers [4.15.4]

Black
Black разместил(а) новый ресурс:

Upgradeable Hoppers - Fast Hopper Plugin Link Containers Item Transfer Suction Chunk - 1.18 Support - Связывание воронок с контейнерами Предметы Воронок Всасывающий патрубок Улучшение производительности

Особенности плагина Upgradeable Hoppers:​

  • Создание неограниченного количества воронок
  • Создавайте неограниченное количество типов воронки с собственными уровнями и дополнительными рецептами
  • Опциональный тип воронки, который всасывает предметы по частям.
  • Неограниченное количество (настраиваемое)
  • Неограниченное количество передачи (настраиваемое)
  • Неограниченный радиус всасывания (настраиваемый)...

Посмотреть страницу этого ресурса...
 
Black
Black обновил ресурс Upgradeable Hoppers - Fast Hopper Plugin Link Containers Item Transfer Suction Chunk - 1.19 Support новой записью:

4.6.2

  • - Исправлено: [#2105] Ошибка при одновременном удалении нескольких воронок, которые влияют на разных игроков
  • - Исправлено: [#2120] Мгновенное всасывание при использовании воронки с чанками и радиусом больше 1

Посмотреть подробности об этом обновлении...
 
Black
Black обновил ресурс Upgradeable Hoppers - Fast Hopper Plugin Link Containers Item Transfer Suction Chunk - 1.19 Support новой записью:

4.7.0

+ Добавлено: [Предложение] Новая опция для hoppers.yml:
Вам нужно вручную добавить его, если вы хотите использовать его.
YAML:
# Должны ли упавшие предметы непосредственно вставляться в бункер такого типа, если он находится в пределах досягаемости и имеет свободное пространство?
    direct-suction: false

Посмотреть подробности об этом обновлении...
 
Black
Black обновил ресурс Upgradeable Hoppers - Fast Hopper Plugin Link Containers Item Transfer Suction Chunk - 1.19 Support новой записью:

4.7.1

  • + Добавлено: Поддержка бочек AdvancedChests и коробок Shulker
  • - Исправлено: [#2162] Игнорирование предела всасывания y для бункеров чанков при мгновенном всасывании

Посмотреть подробности об этом обновлении...
 
Snon_S
Спасибо
 
Black
Black обновил ресурс Upgradeable Hoppers - Fast Hopper Plugin Link Containers Item Transfer Suction Chunk - 1.19 Support новой записью:

4.12.11

  • - Исправлено: [#2297] Отсутствует сообщение об ошибке Tp msg
  • - Исправлено: [#2323] Сохранение ссылок на SQLite из-за ошибки BUSY
  • + Улучшено: Hopper и сохранение ссылок

Посмотреть подробности об этом обновлении...
 
Black
Black обновил ресурс Upgradeable Hoppers - Fast Hopper Plugin Link Containers Item Transfer Suction Chunk - 1.19 Support новой записью:

4.12.16

- Исправлено: [#2294] Неправильное имя опции eco strict в config.yml
YAML:
   items:
     # Если включено, только предметы с одинаковым названием, историей и т.д. будут принадлежать валюте.
      # Не только предметы одного типа или предметы с одинаковыми данными модели.
      strict_2: false
- Исправлено: Неправильная опция списка блоков корюшки в config.yml

Посмотреть подробности об этом обновлении...
 
Black
Black обновил ресурс Upgradeable Hoppers ⭕ Fast Hopper Plugin Link Containers ✅ Item Transfer Suction Chunk - 1.20 новой записью:

4.16.7

+ Добавлено: [Предложение] Добавлен режим постоянной ссылки / отмены ссылки
YAML:
       linking:
          lore:
         - '&8✖ &bLEFT CLICK'
          - '   &7Link this hopper to a container.'
          - '   &7Use SHIFT to keep link mode enabled.'
          - ''
          - '&8✖ &9RIGHT CLICK'
          - '   &7Unlink a container from this hopper.'
          - '   &7Use SHIFT to keep unlink mode enabled.'
          - ''
          - '&8✖ &3DROP'
          - '   &7Cancel link or...

Посмотреть подробности об этом обновлении...
 
maz1lovo
@Black, написано 4.16.7, а скачивается 4.13.7. Исправьте, пожалуйста
 
bobobo
@maz1lovo, не исправим. Все версии согласно основного ресурса.
На спиготе точно так же написано 4.16.7 в версии, а скачиваешь 4.13.7
 
maz1lovo
@bobobo, А.. Если так, то вас понял. Пардон за беспокойство :sweat_smile:
 
Black
Black обновил ресурс Upgradeable Hoppers ⭕ Fast Hopper Plugin Link Containers ✅ Item Transfer Suction Chunk - 1.20 новой записью:

4.13.11

  • - Исправлено: [#2384] вызов асинхронного события
  • + Добавлено: поддержка флага подбора предметов superiorskyblock2
  • + Улучшено: сделать бункеры востребованными, вместо удаления бункеров из базы данных при удалении земли

Посмотреть подробности об этом обновлении...
 
FallenGod
when i run the server, plugin sends this error to me:
[21:56:32] [Server thread/ERROR]: [ModernPluginLoadingStrategy] Could not load plugin 'UpgradeableHoppers-4.13.11(1).jar' in folder 'plugins'
org.bukkit.plugin.InvalidPluginException: java.lang.VerifyError: Bad type on operand stack
Exception Details:
Location:
me/angeschossen/upgradeablehoppers/UpgradeableHoppers.onLoad()V @128: putfield
Reason:
Type 'java/lang/Object' (current frame, stack[1]) is not assignable to 'me/angeschossen/upgradeablehoppers/qGVpb/GAGFH'
Current Frame:
bci: @128
flags: { }
locals: { 'me/angeschossen/upgradeablehoppers/UpgradeableHoppers', 'me/angeschossen/upgradeablehoppers/Lqpzc/XiKV/Srqvu/Srqvu$GAGFH' }
stack: { 'me/angeschossen/upgradeablehoppers/UpgradeableHoppers', 'java/lang/Object' }
Bytecode:
0000000: 2ab3 0060 2ab8 026e 4cb2 0271 2bb6 0274
0000010: 2eab 0000 0000 0021 0000 0001 0000 0001
0000020: 0000 0013 bb02 7659 2bb7 0279 b300 74a7
0000030: 000e bb02 7b59 2bb7 027c b300 742a 2ab8
0000040: 0281 b500 64a7 001c 4d2c b602 842a b602
0000050: 8813 028a b602 8fb8 0294 2ab9 0298 0200
0000060: b12a 2ab4 0064 1302 9ab6 029e 9900 0dbb
0000070: 02a0 59b7 02a1 a700 0abb 02a3 59b7 02a4
0000080: b500 68bb 02a6 592a b400 68b7 02a9 b802
0000090: af2a b602 b22a bb02 b459 b702 b5b5 0070
00000a0: b1
Exception Handler Table:
bci [61, 69] => handler: 72
Stackmap Table:
append_frame(@36,Object[#7])
same_frame(@50)
same_frame(@61)
same_locals_1_stack_item_frame(@72,Object[#133])
same_frame(@97)
same_locals_1_stack_item_frame(@121,Object[#2])
full_frame(@128,{Object[#2],Object[#7]},{Object[#2],Object[#313]})

at io.papermc.paper.plugin.provider.type.spigot.SpigotPluginProvider.createInstance(SpigotPluginProvider.java:127) ~[purpur-1.19.4.jar:git-Purpur-1985]
at io.papermc.paper.plugin.provider.type.spigot.SpigotPluginProvider.createInstance(SpigotPluginProvider.java:35) ~[purpur-1.19.4.jar:git-Purpur-1985]
at io.papermc.paper.plugin.entrypoint.strategy.modern.ModernPluginLoadingStrategy.loadProviders(ModernPluginLoadingStrategy.java:116) ~[purpur-1.19.4.jar:git-Purpur-1985]
at io.papermc.paper.plugin.storage.SimpleProviderStorage.enter(SimpleProviderStorage.java:39) ~[purpur-1.19.4.jar:git-Purpur-1985]
at io.papermc.paper.plugin.entrypoint.LaunchEntryPointHandler.enter(LaunchEntryPointHandler.java:36) ~[purpur-1.19.4.jar:git-Purpur-1985]
at org.bukkit.craftbukkit.v1_19_R3.CraftServer.loadPlugins(CraftServer.java:445) ~[purpur-1.19.4.jar:git-Purpur-1985]
at net.minecraft.server.dedicated.DedicatedServer.initServer(DedicatedServer.java:310) ~[purpur-1.19.4.jar:git-Purpur-1985]
at net.minecraft.server.MinecraftServer.runServer(MinecraftServer.java:1120) ~[purpur-1.19.4.jar:git-Purpur-1985]
at net.minecraft.server.MinecraftServer.lambda$spin$0(MinecraftServer.java:325) ~[purpur-1.19.4.jar:git-Purpur-1985]
at java.lang.Thread.run(Thread.java:833) ~[?:?]
Caused by: java.lang.VerifyError: Bad type on operand stack
Exception Details:
Location:
me/angeschossen/upgradeablehoppers/UpgradeableHoppers.onLoad()V @128: putfield
Reason:
Type 'java/lang/Object' (current frame, stack[1]) is not assignable to 'me/angeschossen/upgradeablehoppers/qGVpb/GAGFH'
Current Frame:
bci: @128
flags: { }
locals: { 'me/angeschossen/upgradeablehoppers/UpgradeableHoppers', 'me/angeschossen/upgradeablehoppers/Lqpzc/XiKV/Srqvu/Srqvu$GAGFH' }
stack: { 'me/angeschossen/upgradeablehoppers/UpgradeableHoppers', 'java/lang/Object' }
Bytecode:
0000000: 2ab3 0060 2ab8 026e 4cb2 0271 2bb6 0274
0000010: 2eab 0000 0000 0021 0000 0001 0000 0001
0000020: 0000 0013 bb02 7659 2bb7 0279 b300 74a7
0000030: 000e bb02 7b59 2bb7 027c b300 742a 2ab8
0000040: 0281 b500 64a7 001c 4d2c b602 842a b602
0000050: 8813 028a b602 8fb8 0294 2ab9 0298 0200
0000060: b12a 2ab4 0064 1302 9ab6 029e 9900 0dbb
0000070: 02a0 59b7 02a1 a700 0abb 02a3 59b7 02a4
0000080: b500 68bb 02a6 592a b400 68b7 02a9 b802
0000090: af2a b602 b22a bb02 b459 b702 b5b5 0070
00000a0: b1
Exception Handler Table:
bci [61, 69] => handler: 72
Stackmap Table:
append_frame(@36,Object[#7])
same_frame(@50)
same_frame(@61)
same_locals_1_stack_item_frame(@72,Object[#133])
same_frame(@97)
same_locals_1_stack_item_frame(@121,Object[#2])
full_frame(@128,{Object[#2],Object[#7]},{Object[#2],Object[#313]})

at java.lang.Class.forName0(Native Method) ~[?:?]
at java.lang.Class.forName(Class.java:467) ~[?:?]
at org.bukkit.plugin.java.PluginClassLoader.<init>(PluginClassLoader.java:78) ~[purpur-api-1.19.4-R0.1-SNAPSHOT.jar:?]
at io.papermc.paper.plugin.provider.type.spigot.SpigotPluginProvider.createInstance(SpigotPluginProvider.java:123) ~[purpur-1.19.4.jar:git-Purpur-1985]
... 9 more
 
Black
Black обновил ресурс Upgradeable Hoppers ⭕ Fast Hopper Plugin Link Containers ✅ Item Transfer Suction Chunk - 1.20 новой записью:

4.13.16

  • - Исправлено: направленное всасывание засасывало предметы, находящиеся ниже радиуса бункера (бункеры без кусков)
  • - Исправлено: Ошибка локализации на спиготе

Посмотреть подробности об этом обновлении...
 
Black
Black обновил ресурс Upgradeable Hoppers новой записью:

4.13.19

+ Добавлено: опция inv-sync
YAML:
  # Следует ли регулярно синхронизировать состояние инвентаризации ссылок?
  # Эта опция должна быть включена, если вы используете сторонние плагины, изменяющие контейнеры.
  inv-sync: true

Посмотреть подробности об этом обновлении...
 
Black
Black обновил ресурс Upgradeable Hoppers новой записью:

4.13.23

Старые пользовательские текстуры голов больше не поддерживаются сервером.
Поэтому необходимо изменить все пользовательские головки в файле GUI на новые
URL-адреса скинов.
  • Здесь вы можете найти более подробную информацию о том, как это сделать: New Head Textures.
  • Если вы хотите использовать новые пользовательские головки плеера по умолчанию:
    • Пользовательские головки GUI по умолчанию...

Посмотреть подробности об этом обновлении...
 
Black
Black обновил ресурс Upgradeable Hoppers новой записью:

4.14.0

+ Добавлено: Теперь можно задавать имена для хопперов
Возможно, вы захотите изменить предмет списка для меню /hopper list:
YAML:
       entry_object:
          lore: '&8✖ &7Open the hoppers menu.[newline][newline]&8✖ &9RIGHT CLICK[newline]   &7Teleport
            to the hopper[newline]   &7for&c {cost}&7.[newline]&8✖ &3DROP[newline]   &7Delete
            this hopper.[newline]    &8• &cThe item can''t be given[newline]      &cback
            to you, if the area[newline]      &cisn''t...

Посмотреть подробности об этом обновлении...
 
Black
Black обновил ресурс Upgradeable Hoppers новой записью:

4.15.0

+ Добавлено: [Предложение] Визуализация для радиуса всасывания
Убедитесь, что предмет "Всасывание" в языковом файле GUI обновлен соответствующим образом:
YAML:
       upgrade_suction_radius:
          lore: '&8✖ &7Upgrade the suction radius.[newline]   &7The hopper sucks all
            items that[newline]   &7are in this radius.[newline][newline]   &8• &7Current:
           {value}[newline]   &8• &7Next:&a {value_next}[newline]     &7Cost:&c
            {cost}[newline][newline]&8✖...

Посмотреть подробности об этом обновлении...
 
Black
Black обновил ресурс Upgradeable Hoppers новой записью:

4.15.2

  • - Исправлено: [#2502] Проблемы с получением данных о скинах для голов и т.д. Это наконец-то устраняет ошибки, выводимые API сервера. Которые могут возникнуть, если API Mojangs не работает и т.д.

Посмотреть подробности об этом обновлении...
 
TopBottom