• The price for the GOLD and Unlimited groups has been reduced by 22%. Don't miss the chance to purchase access to hundreds of great resources.
    Coupon: BM_TOPBuy the group

Gold  Plugin Protection Managing worlds GriefDefender [2.5.5]

This resource can be downloaded by users with a band GOLD or higher. Read More/Buy
Еще одно быстрое исправление, чтобы применить те же изменения из 2.5.4 к '/claimexpand' и '/claimcontract'

2.5.5 Changelog​

  • - Исправление переданных дочерних утверждений, позволяющих изменять размер без доверия менеджера к родителю при использовании '/claimexpand' или '/claimcontract'
Это еще одно исправление, поскольку мы поняли, что удаление 'context-storage-type' было не самой лучшей идеей.

Тип контекстного хранилища

Вот как теперь будет работать 'context-storage-type' при использовании на общем хранилище DB :

global - GD будет запрашивать все утверждения и игнорировать контекст сервера LP. Если вы НЕ хотите, чтобы сервер учитывался в общей стоимости блока претензий игрока, то вам следует изменить префикс его таблицы или перенести сервер в отдельную БД GD.

сервер - GD будет запрашивать все иски, соответствующие контексту сервера LP. Например, если у вас есть 3 сервера выживания, все они используют контекст сервера LP 'survival', и вы хотите, чтобы GD делил блоки между этими тремя серверами, то вам следует использовать именно эту опцию.

Примечание: Если вы НЕ хотите делиться блоками ни с одним другим сервером, вы можете иметь уникальный контекст сервера LP или установить 'force-server-only' в 'true'.

world - GD запросит все иски, соответствующие UUID текущего сервера и мира. Это используется, если вы хотите, чтобы у игроков были отдельные данные блоков для каждого мира.


2.5.3 Changelog​

  • * Отменено изменение 'context-storage-type' в 2.5.2.
  • * Обновление глобальной логики 'context-storage-type' для учета всех требований в БД независимо от контекста сервера LP.
  • * Добавлена настройка 'force-server-only' для сервера, который не хочет делиться данными о блоках игроков с другими серверами.
  • * Дополнительные исправления для 'protected-worlds'
  • * Исправление доверия к проверке повреждений сущностей для таких действий, как падение игрока.
ВАЖНО:
Для новой опции player-deny-glide были добавлены новые записи в lang.
Вы можете удалить папку lang, чтобы заново создать ее с новыми записями, или добавить следующие :
YAML:
option-apply-player-deny-glide="&cYou do not have access to glide in this claim and have been teleported to a safe spot on ground."
option-description-player-deny-glide="&aUsed to determine if a player is unable to glide in a claim.\n&dNote&f: This does not give players the ability to glide, it merely removes the ability if set. This provides the greatest compatibility with plugins."
permission-build-chest-border="&cYou are not allowed to place a chest next to a chest that is not in a claim you're trusted in."
player-deny-glide="Controls whether a player has ability to glide in this claim."
player-deny-glide=player-deny-glide
Конфигурация тегов

GD теперь предоставляет собственный файл tag.conf для администраторов серверов, позволяющий легко создавать новые группы тегов, используемые в качестве контекстов для 1 или более идентификаторов. Это альтернатива датапакам и для некоторых гораздо проще в использовании.


Опция скольжения игрока
GD теперь предоставляет новую опцию под названием "player-deny-glide". Эта новая опция позволит администраторам серверов запрещать скольжение надкрыльев в исках.
Примечание: эта опция не влияет на обычные полеты.


Улучшения в гибридах
Регистрация сущностей мода была обновлена для поддержки последних изменений Mohist/Magma/Arclight.
Добавлен новый провайдер пиксельмонов, чтобы обеспечить новые контексты, такие как определение того, спаунится ли пиксельмон как дикий или нет.


2.5.1 Changelog​

  • * Исправление ошибки изменения размера, когда при использовании DB-хранилища не обновлялись оставшиеся блоки.
  • * Исправление перевода ui-click-to-see в de_DE.
  • * Исправление неработающих данных модели в графическом интерфейсе инвентаря.
  • * Исправление NPE в handleBlockModifyEvent при отключенном мире GD.
  • * Исправление неправильной проверки флага pvp для всех пользователей.
  • * Исправление перерождений в обход проверки пограничных требований.
  • * Исправить отображение таймера истечения срока действия, когда срок действия установлен на 0.
  • * Исправление метода GDOption getPermission.
  • * Исправление getActiveOptionValue при передаче null claim.
  • * (Гибрид) Исправление регистрации гибридных сущностей в MC 1.18.2+
  • * Добавьте новый tag.conf для упрощения добавления пользовательских тегов.
  • * Добавлена новая опция игрока player-deny-glide для контроля того, может ли игрок скользить в иске.
  • * Добавлено новое сообщение о защите при попытке поставить сундук рядом с другим сундуком в недоверенной претензии.
  • * Добавлена новая настройка respawns-use-border-event для контроля того, должны ли респауны проверять флаги enter-claim и exit-claim.
  • * Добавлен новый контекст игрока gliding, когда надкрылья экипированы.
  • * (Гибрид) Добавлен новый провайдер пиксельмонов для поддержки следующих новых контекстов
    • pokemon_battling
    • pokemon_lvl
    • pokemon_spawn_loc_type
    • pokemon_spawn_type
    • pokemon_type
    • pokeball_type
  • Примечание: Используйте source=spawnreason:natural и pokemon_spawn_type=wild, если вы хотите блокировать только дикие спавны.
  • * Обновление файла it_IT preset lang. (Предоставлено Tig3r)
ВАЖНО:
Примечание: Новые серверы могут пропустить этот раздел.
Перед обновлением до версии 2.5.0+ создайте резервную копию LP/GD, так как в ней есть несколько серьезных изменений.
Существующие серверы должны выполнить следующие действия перед обновлением до 2.5.0+
GD 2.5.0+ требует следующих изменений для групп GD в LP :

Чейджлог​

1. Родительские группы LP по умолчанию (НЕ GD) должны быть только griefdefender_option и griefdefender_override.
2. Удалены родительские группы из групп griefdefender_trust_<type>.
3. Настройте веса групп griefdefender_trust_<type> следующим образом
  • griefdefender_trust_manager должен иметь вес -70
  • griefdefender_trust_builder должен иметь вес -71
  • griefdefender_trust_container должен иметь вес -72
  • griefdefender_trust_accessor должен иметь вес -73
  • горе-оборонщик_траст_резидент должен иметь вес -74
4. Установите значение 'luckperms-playerdata' в true в разделе migrator в global.conf.
Примечание: Если вы не видите этот параметр, просто добавьте его вручную и установите значение true.
5. Добавьте новый элемент lang 'label-expiration=Expiration' или очистите папку lang, чтобы сгенерировать чистую версию.

Поддержка MC 1.20.4​

Это минорный выпуск, который добавляет поддержку серверов Minecraft 1.20.4 и исправляет некоторые ошибки.

Changelog​

  • Добавлена поддержка MC 1.20.4.
  • Исправлен метод поиска UUID в автономном режиме.
Примечание: Это исправляет команды типа /trust, которые не всегда срабатывали с первого раза для оффлайн-пользователей.
  • Исправление оффлайнового поиска имени пользователя, иногда возвращающего UUID вместо имени.
  • Исправление того, что RemoveClaimEvent не передавал удаленные дочерние утверждения.
Примечание: Это исправляет ситуацию, когда DynMap/BlueMap/SquareMap не удаляли дочерние иски с карты при удалении родительского иска.
  • Исправление того, что игроки не могли есть в недоверенных претензиях.
  • Исправление того, что тег еды не добавлялся для контекста used_item.
  • Исправление того, что контексты игроков не отображались в кэшированных результатах отладки.
  • Исправление невозможности экипировать надкрылья при нацеливании на блок в недоверенных исках.
  • Исправление невозможности экипировать броню при нацеливании на блок в недоверенных исках.
В этом обновлении устранена проблема, связанная с возможностью изменения размера регионов WorldGuard.
  • * Проверка на перекрытие регионов WorldGuard при изменении размеров GD-требований.
  • * Исправление того, что определения, использующие переопределяющие контексты, не имели наивысшего приоритета при поиске групп GD.
Примечание: Все определения, использующие переопределяющие контексты, при запуске будут применяться в LP как сохраняемые разрешения. Если вы удалите определение, содержащее контекст переопределения, или измените его значение по умолчанию, вам необходимо вручную удалить старые разрешения из LP в группе 'griefdefender_override'.
  • * Исправление того, что при поиске разрешений по умолчанию не проверялись нужные группы.
  • * Исправление наследования групп GD.
  • * Исправление того, что команда '/cf' не отображала нужную целевую группу.
  • * Исправление не обновляющихся переключателей GUI группы доверия.
  • * Исправление атак прирученных владельцем сущностей, не проходивших через разрешения.
  • * Исправление того, что команда 'default-groups' не работала с группами griefdefender_trust.
В этом выпуске добавлены различные улучшения и исправления ошибок.

Улучшена отладка флагов​

Команда отладки флагов GD 'gddebug' теперь предоставляет новый столбец под названием 'Definition'. В этом столбце будут отображаться все определения флагов, которые соответствуют действию, выполняемому игроком.

Например, если игрок щелкнул правой кнопкой мыши на сундуке, то в предыдущих версиях в колонке флагов отображалось только 'interact-inventory'. В версии 2.4.3 в дополнительном столбце "Определение" будет отображаться "доступ к сундуку" и все другие определения, использующие тот же флаг и контекст действия.

Настройки графического интерфейса инвентаря​

Конфиг GUI GD (gui.conf) теперь генерирует ряд/слот для большинства иконок, что дает администраторам возможность перемещать иконки по своему усмотрению. Если ряд/слот не указан, GD вернется к размещению по умолчанию.

Changelog​

  • - Исправление того, что права администратора/владельца дикой природы не проверялись должным образом.
  • - Исправление того, что interact-inventory-click не проверялся, если был отключен во время событий.
  • - Исправление того, что gddebug иногда не показывал нужного пользователя.
  • - Исправление случайных сообщений о претензиях, отправляемых игрокам с включенной функцией 'async-claim-tool-actions'.
  • - Улучшена обработка ошибок в графическом интерфейсе инвентаря.
  • - Добавить колонку определения флага в gddebug.
  • - Добавлена поддержка настройки строк/слотов в графическом интерфейсе инвентаря.
  • - (Fabric/Forge) Исправление NPE при проверке претензий.
В этом обновлении устранено несколько важных проблем, связанных с предыдущими версиями 2.4.X.

Changelog
  • Исправлен поиск опций, иногда возвращающих неверное значение из-за возможной проблемы с кэшем БД LP.
  • Исправлена проверка контекстов GD по умолчанию на владельцев претензий.
  • Исправление отказа владельцам претензий во взрывах в их претензиях.
  • Исправлена проверка черного списка игрока на взаимодействие с блоком-вторичкой.
  • Защитить узел поводка при нажатии правой кнопки мыши по умолчанию.
  • По умолчанию защищать жителей деревни от взрывов ТНТ.
  • Группы доверия LP GD больше не наследуют друг друга. Чтобы исправить это в существующих настройках, используйте /lp editor и удалите любую родительскую группу из групп griefdefender_trust_xxx.
  • (MC 1.12.2) Исправление ошибки NoSuchMethodError при BlockMultiPlaceEvent.
  • (Fabric/Forge) Исправление NPE при уведомлении о блоке.
TopBottom